Как добавить ставку НДС 20% в старые редакции «1С:Управление торговлей»?

Существует несколько редакций программного продукта «1С:Управление торговлей 8», но не все редакции в настоящее время поддерживаются фирмой «1С», обновления с новой ставкой НДС 20% вышли только для редакций 10.3 и 11.4, для остальных версий программы обновления больше не выпускают.

О новых релизах программы «1С:Управление торговлей 8» с НДС 20%, выпущенных фирмой «1С», можно узнать по ссылке.

Ставку НДС 20% в 1С:Управление торговлей, редакция 11.0″, как добавить?

Что делать тем организациям, кто не перешел на редакцию 11.4? Если программа доработана и доработок много, переход на новую редакцию может оказаться трудоемким и дорогостоящим, в таком случае проще добавить ставку НДС 20% в текущую конфигурацию, без перехода на новую редакцию.

В этой статье будет показано, как добавить ставку НДС 20% в редакцию 11.0 программного продукта «1С: Управление торговлей 8».

В первую очередь нужно сделать архивную копию базы данных. В конфигураторе 1С открываем перечисления, находим перечисление «СтавкиНДС» и добавляем два новых значения:

Как добавить ставку НДС 20% в старые редакции "1С:Управление торговлей"?

Далее нужно найти функцию ПолучитьСтавкуНДСЧислом, она находится или в общем модуле ЦенообразованиеПовтИсп или ЦенообразованиеКлиентСервер в зависимости от релиза программы. Функция находится в модуле ЦенообразованиеПовтИсп в более ранних версиях редакции 11.0. Нужно в этой функции скопировать строки от «ИначеЕсли» до «Возврат 0.18;» и вставить ниже:

Как добавить ставку НДС 20% в старые редакции "1С:Управление торговлей"?

Меняем в скопированных строках 18 на 20:

Как добавить ставку НДС 20% в старые редакции "1С:Управление торговлей"?

Сохраняем изменения и проверяем, как работают документы со ставками НДС. Новая ставка должна выбираться, суммы в документах должны пересчитываться при изменении ставки НДС. Также необходимо в карточках номенклатуры изменить ставки НДС для автоматического заполнения ставки в документах.

В этой статье можно прочитать, как изменить в справочнике «Номенклатура» заполненную ставку НДС после обновления программы на последнюю версию, с новой ставкой НДС — 20%.

Как добавить ставку НДС 20% в старый релиз «1С:Платежные документы»

    1. Добавляем в перечисления «Ставки НДС» значение НДС20:Как добавить ставку НДС 20% в старые редакции "1С:Управление торговлей"?
    2. Заполняете свойства нового элемента как на картинке:

Как добавить ставку НДС 20% в старые редакции "1С:Управление торговлей"?

3. Далее надо найти общий модуль «ОбработкаТабличныхЧастей», он находится в дереве конфигурации здесь:

Как добавить ставку НДС 20% в старые редакции "1С:Управление торговлей"?

В это модуле надо заменить код функции ПолучитьСтавкуНДС на следующий:

Функция ПолучитьСтавкуНДС(СтавкаНДС) Экспорт

     Если СтавкаНДС = Перечисления.СтавкиНДС.НДС10 Тогда

            Возврат 10;

     ИначеЕсли СтавкаНДС = Перечисления.СтавкиНДС.НДС18 Тогда

            Возврат 18;

     ИначеЕсли СтавкаНДС = Перечисления.СтавкиНДС.НДС20 Тогда

            Возврат 20;

     КонецЕсли;

     Возврат 0;

КонецФункции // ПолучитьСтавкуНДС()

Или просто добавить строки, относящиеся к новой ставке НДС.

4. Далее открыть форму документа ПлатежноеПоручениеИсходящее:

Как добавить ставку НДС 20% в старые редакции "1С:Управление торговлей"?

Внизу вкладка — Модуль, в нем заменяем код в процедуре УстановитьСтавкуНДС на следующий:

Процедура УстановитьСтавкуНДС()

Если УказатьНДС Тогда

        СтавкаНДС = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глТекущийПользователь, «ОсновнаяСтавкаНДС»);

       Если НЕ ЗначениеЗаполнено(СтавкаНДС) Тогда

                  СтавкаНДС = Перечисления.СтавкиНДС.НДС20;

       КонецЕсли;

                Иначе

                       СтавкаНДС = Перечисления.СтавкиНДС.ПустаяСсылка();

                КонецЕсли;

КонецПроцедуры

Или заменить в коде строку со ставкой НДС с 18 на 20.

Если не знаете, как открыть конфигурацию, выберите в меню пункт Конфигурация-Открыть конфигурацию.

Если не можете изменять конфигурацию, ее надо сначала снять с поддержки:

Как добавить ставку НДС 20% в старые редакции "1С:Управление торговлей"?

В форме настройки нажать кнопку «Включить возможность изменения» и установить правила как на картинке:

Как добавить ставку НДС 20% в старые редакции "1С:Управление торговлей"?

Нажать ОК.

Это все изменения в конфигурации Платежные документы, связанные с добавлением новой ставки НДС.

Еще в режиме 1С:Предприятие (режиме работы пользователя с программой) зайдите в меню Сервис-Настройки пользователя и установите там ставку НДС по умолчанию 20%.

Перед любыми изменениями конфигурации делайте архивную копию базы!

9 Комментарии
  1. Екатерина говорит

    Здравствуйте! У меня 1с Розница, версия 2.2.9.20. Сделала все, как написано (очень понятно, кстати, для таких новичков как я)). После отладки ставка 20% не появляется. В чем может быть проблема? Заранее спасибо

  2. admin говорит

    Здравствуйте! В Рознице установлен фильтр в справочнике Номенклатура в поле «Ставка НДС». Добавить 20% можно следующим образом: в конфигураторе найти справочник Номенклатура, в нем открыть форму элемента, в форме ткнуть мышью в поле «Ставка НДС», далее — по правой кнопке мыши открыть контекстное меню, в нем выбрать «Свойства», в свойствах найти «Список выбора», нажать три точки справа, в списке нажать кнопку «Заполнить», удалить лишние значения (нулевую ставку НДС, ставки вида 18%/118%), сохранить и обновить конфигурацию. Но этого недостаточно, чтобы ставка НДС 20% появилась в документах, там тоже аналогичные фильтры, все немного сложнее, чем в торговле, лучше написать отдельную статью, чтобы было понятно.
    Есть еще один момент, если у вас онлайн-касса, то с нового года поменялись форматы обмена с налоговой, без штрафов и без обновления можно еще работать до конца марта, а потом надо обновить драйвер ККМ и программу, и такая доработка не будет иметь смысла, если только как временный вариант.

    1. Екатерина говорит

      Спасибо большое! Все получилось! Внесла изменения в формы. Кассы обновим. Мы вообще без НДС работаем, но хотелось все исправить! Ещё раз спасибо за помощь!!

  3. Серей говорит

    Здравствуйте. У меня утановлена программа 1С платежные документы8. Можно ли поменять ставку на 20 как описано у вас у меня не получается (нет НДС20, НДС20_120)

    1. admin говорит

      Добавила в конец статьи.

  4. Серей говорит

    Здравствуйте. А если в меню Поддержки нет пункта Настройка поддержки? У меня там всего два пункта Обновить конфигурацию и Шаблоны конфигураций и обновлений.

    1. admin говорит

      Можете написать номер версии платформы и конфигурации? Зайти в режиме 1С:Предприятие (режиме пользователя) в меню Справка-О программе. Номер в скобках после слов «1С:Предприятие» и после «1С:Платежные документы».

  5. Ольга говорит

    Здравствуйте. Нет возможности обновить УТ 11.4 , дописала на тестовой базу , все получилось. Это здорово, только один вопрос: не вылезет ли потом боком эта «допись» в закрытиях месяца, в ккм и т.д…Ведь наверняка где-то в коде ещё спрятано это НДС , где мы ничего не изменяем

    1. admin говорит

      Чтобы проверить, нужно взять предыдущий релиз УТ, который вышел перед тем, как добавили ставку 20% и сделать сравнение в конфигураторе с конфигурацией релиза с новой ставкой, тогда будут видные все изменения, касающиеся новой ставки НДС. Вы так не сможете сделать, а мне надо время найти.
      Делала аналогичную проверку для 1С:Платежные документы, в обновлении было все то же самое, что я предлагаю вручную добавить, но та конфигурация очень простая по сравнению с УТ.
      Что касается ККМ, еще нужно обновление драйвера или прошивки, точно не скажу, не очень дружу с торговым оборудованием.

Оставьте ответ

Ваш электронный адрес не будет опубликован.

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.